Skip to content

Latest commit

 

History

History
41 lines (29 loc) · 787 Bytes

1933.md

File metadata and controls

41 lines (29 loc) · 787 Bytes

1933题目描述:输出梯形

输入一个高度h,输出一个高为h,上底边为h的梯形。

  • 输入

一个整数h(1<=h<=1000)。

  • 输出

h所对应的梯形。

  • 样例输入

5

  • 样例输出

这里写图片描述

#include <iostream>
using namespace std;
int main() {
    int h,w;
    while(cin>>h) {
        w = h + 2 * (h - 1);
        for (int i = 0; i < h; i++) {
            for (int j = 0; j < w; j++) {
                if (j < (w - (h + i * 2))) cout << ' ';
                else cout << '*';
            }
            cout << endl;
        }
    }
    return 0;
}