You signed in with another tab or window. Reload to refresh your session.You signed out in another tab or window. Reload to refresh your session.You switched accounts on another tab or window. Reload to refresh your session.Dismiss alert
Add Sankey diagram visuals: sankey_drake_graph() and render_sankey_drake_graph().
Add static_drake_graph() and render_static_drake_graph() for ggplot2/ggraph static graph visualizations.
Add group and clusters arguments to vis_drake_graph(), static_drake_graph(), and drake_graph_info() to optionally condense nodes into clusters.
Implement a trace argument to evaluate_plan() to optionally add indicator columns to show which targets got expanded/evaluated with which wildcard values.
Rename the always_rename argument to rename in evaluate_plan().
Add a rename argument to expand_plan().
Implement make(parallelism = "clustermq_staged"), a clustermq-based staged parallelism backend (see #452).
Implement make(parallelism = "future_lapply_staged"), a future-based staged parallelism backend (see #450).
Depend on codetools rather than CodeDepends for finding global variables.
Detect loadd() and readd() dependencies in knitr reports referenced with knitr_in() inside imported functions. Previously, this feature was only available in explicit knitr_in() calls in commands.
Skip more tests on CRAN. White-list tests instead of blacklisting them in order to try to keep check time under the official 10-minute cap.
Disallow wildcard names to grep-match other wildcard names or any replacement values. This will prevent careless mistakes and confusion when generating drake_plan()s.
Prevent persistent workers from hanging when a target fails.
Deprecate drake_batchtools_tmpl_file() in favor of drake_hpc_template_file() and drake_hpc_template_files().
Add a garbage_collection argument to make(). If TRUE, gc() is called after every new build of a target.
Remove redundant calls to sanitize_plan() in make().
Change tracked() to accept only a drake_config() object as an argument. Yes, it is technically a breaking change, but it is only a small break, and it is the correct API choice.
Move visualization and hpc package dependencies to "Suggests:" rather than "Imports:" in the DESCRIPTION file.
Allow processing of codeless knitr reports without warnings.