Skip to content

Commit

Permalink
perlcritic: add missing new dependencies
Browse files Browse the repository at this point in the history
Signed-off-by: Konrad Weihmann <kweihmann@outlook.com>
  • Loading branch information
priv-kweihmann committed Feb 1, 2025
1 parent bc93619 commit 65ba58e
Show file tree
Hide file tree
Showing 6 changed files with 77 additions and 1 deletion.
Original file line number Diff line number Diff line change
@@ -0,0 +1,16 @@
SUMMARY = "Call isa, can, does and DOES safely on things that may not be objects"
HOMEPAGE = "https://metacpan.org/pod/Safe::Isa"

DEFAULT_PREFERENCE = "${SCA_DEFAULT_PREFERENCE}"
LICENSE = "GPL-2.0-only & Artistic-1.0"
LIC_FILES_CHKSUM = "file://README;beginline=147;md5=87e1d51b7bf1b1a730156174d3235554"

SRC_URI = "https://cpan.metacpan.org/authors/id/E/ET/ETHER/Safe-Isa-${PV}.tar.gz"

SRC_URI[sha256sum] = "87f4148aa0ff1d5e652723322eab7dafa3801c967d6f91ac9147a3c467b8a66a"

UNPACKDIR ??= "${WORKDIR}/sources"
S = "${UNPACKDIR}/Safe-Isa-${PV}"

inherit cpan
inherit_defer nativesdk
16 changes: 16 additions & 0 deletions recipes-perl/perl-safe-isa-native/perl-safe-isa-native_1.000010.bb
Original file line number Diff line number Diff line change
@@ -0,0 +1,16 @@
SUMMARY = "Call isa, can, does and DOES safely on things that may not be objects"
HOMEPAGE = "https://metacpan.org/pod/Safe::Isa"

DEFAULT_PREFERENCE = "${SCA_DEFAULT_PREFERENCE}"
LICENSE = "GPL-2.0-only & Artistic-1.0"
LIC_FILES_CHKSUM = "file://README;beginline=147;md5=87e1d51b7bf1b1a730156174d3235554"

SRC_URI = "https://cpan.metacpan.org/authors/id/E/ET/ETHER/Safe-Isa-${PV}.tar.gz"

SRC_URI[sha256sum] = "87f4148aa0ff1d5e652723322eab7dafa3801c967d6f91ac9147a3c467b8a66a"

UNPACKDIR ??= "${WORKDIR}/sources"
S = "${UNPACKDIR}/Safe-Isa-${PV}"

inherit cpan
inherit_defer native
18 changes: 18 additions & 0 deletions recipes-perl/perl-yaml-pp-native/nativesdk-perl-yaml-pp_0.38.1.bb
Original file line number Diff line number Diff line change
@@ -0,0 +1,18 @@
SUMMARY = "YAML 1.2 processor"
HOMEPAGE = "https://metacpan.org/pod/YAML::PP"

DEFAULT_PREFERENCE = "${SCA_DEFAULT_PREFERENCE}"
LICENSE = "GPL-2.0-only & Artistic-1.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ed15294933f5d94828e02d243070d415"

SRC_URI = "https://cpan.metacpan.org/authors/id/T/TI/TINITA/YAML-PP-v${PV}.tar.gz"

SRC_URI[sha256sum] = "cf5f1096af3ea5c036d838847b213a613e9a85b757962bacf508d4ad72f88f49"

UNPACKDIR ??= "${WORKDIR}/sources"
S = "${UNPACKDIR}/YAML-PP-v${PV}"

inherit cpan
inherit_defer nativesdk

UPSTREAM_CHECK_REGEX = "YAML-PP-v(?P<pver>\d+.\d+(.\d+)*).tar.gz"
18 changes: 18 additions & 0 deletions recipes-perl/perl-yaml-pp-native/perl-yaml-pp-native_0.38.1.bb
Original file line number Diff line number Diff line change
@@ -0,0 +1,18 @@
SUMMARY = "YAML 1.2 processor"
HOMEPAGE = "https://metacpan.org/pod/YAML::PP"

DEFAULT_PREFERENCE = "${SCA_DEFAULT_PREFERENCE}"
LICENSE = "GPL-2.0-only & Artistic-1.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ed15294933f5d94828e02d243070d415"

SRC_URI = "https://cpan.metacpan.org/authors/id/T/TI/TINITA/YAML-PP-v${PV}.tar.gz"

SRC_URI[sha256sum] = "cf5f1096af3ea5c036d838847b213a613e9a85b757962bacf508d4ad72f88f49"

UNPACKDIR ??= "${WORKDIR}/sources"
S = "${UNPACKDIR}/YAML-PP-v${PV}"

inherit cpan
inherit_defer native

UPSTREAM_CHECK_REGEX = "YAML-PP-v(?P<pver>\d+.\d+(.\d+)*).tar.gz"
Original file line number Diff line number Diff line change
Expand Up @@ -25,11 +25,13 @@ DEPENDS += "\
nativesdk-perl-ppix-regexp \
nativesdk-perl-ppix-utilities \
nativesdk-perl-readonly \
nativesdk-perl-safe-isa \
nativesdk-perl-string-format \
nativesdk-perl-task-weaken \
nativesdk-perl-term-ansicolor \
nativesdk-perl-test-deep \
nativesdk-perl-text-parsewords \
nativesdk-perl-yaml-pp \
perl-b-keywords-native \
perl-exporter-tiny-native \
perl-list-moreutils-native \
Expand All @@ -43,20 +45,24 @@ S = "${UNPACKDIR}/git"
UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>1\.\d{3})"

inherit cpan_build

inherit sca-description
inherit_defer nativesdk

SCA_TOOL_DESCRIPTION = "perlcritic"

do_compile () {
perl Build verbose=1
}

do_install:append() {
sed -i "s#/.*/bin/perl#/usr/bin/env perl#g" ${D}${bindir}/perlcritic
# Remove .packlist file, as it contains host specific paths
# and doesn't serve a real purpose
find ${D} -name ".packlist" -delete
}

INSANE_SKIP:${PN} += "shebang-size"

RDEPENDS:${PN}:class-nativesdk += "\
nativesdk-perl \
nativesdk-perl-class-data-inheritable \
Expand Down
2 changes: 2 additions & 0 deletions recipes-sca/perl-critic-native/perl-critic-native_1.154.bb
Original file line number Diff line number Diff line change
Expand Up @@ -28,11 +28,13 @@ DEPENDS += "\
perl-ppix-regexp-native \
perl-ppix-utilities-native \
perl-readonly-native \
perl-safe-isa-native \
perl-string-format-native \
perl-task-weaken-native \
perl-term-ansicolor-native \
perl-test-deep-native \
perl-text-parsewords-native \
perl-yaml-pp-native \
"

SRC_URI = "git://github.com/Perl-Critic/Perl-Critic.git;branch=master;protocol=https"
Expand Down

0 comments on commit 65ba58e

Please sign in to comment.