Skip to content

Commit

Permalink
WIP test of mac CI builds, without liberaforms IFD
Browse files Browse the repository at this point in the history
  • Loading branch information
cleeyv committed Jul 26, 2023
1 parent a0b4267 commit d851866
Show file tree
Hide file tree
Showing 5 changed files with 11 additions and 8 deletions.
8 changes: 5 additions & 3 deletions .github/workflows/ci.yaml
Original file line number Diff line number Diff line change
Expand Up @@ -4,20 +4,22 @@ on:
push:
pull_request:

env:
NIXPKGS_ALLOW_UNSUPPORTED_SYSTEM: 1

jobs:
check-linux:
runs-on: ubuntu-22.04
steps:
- uses: actions/checkout@v3
- uses: DeterminateSystems/nix-installer-action@main
- uses: DeterminateSystems/magic-nix-cache-action@main
- run: nix flake check --allow-import-from-derivation
- run: nix flake check --impure

check-mac:
runs-on: macos-latest
steps:
- uses: actions/checkout@v3
- uses: DeterminateSystems/nix-installer-action@main
- uses: DeterminateSystems/magic-nix-cache-action@main
- run: nix flake check --allow-import-from-derivation

- run: nix flake check --impure
4 changes: 2 additions & 2 deletions all-packages.nix
Original file line number Diff line number Diff line change
Expand Up @@ -3,8 +3,8 @@ let
self = rec {
libgnunetchat = callPackage ./pkgs/libgnunetchat { };
gnunet-messenger-cli = callPackage ./pkgs/gnunet-messenger-cli { };
liberaforms = callPackage ./pkgs/liberaforms { };
liberaforms-env = callPackage ./pkgs/liberaforms/env.nix { };
#Disabled because IFD# liberaforms = callPackage ./pkgs/liberaforms { };
#Disabled because IDF# liberaforms-env = callPackage ./pkgs/liberaforms/env.nix { };
};

callPackage = newScope self;
Expand Down
2 changes: 1 addition & 1 deletion configs/all-configurations.nix
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
{ pkgs }:
{
liberaforms-container = import ./liberaforms/container.nix;
#Disabled because IDF# liberaforms-container = import ./liberaforms/container.nix;
}
3 changes: 2 additions & 1 deletion flake.nix
Original file line number Diff line number Diff line change
Expand Up @@ -22,6 +22,7 @@
# to muck around with overlays (which don't work with flakes as you'd expect)
_module.args.ngipkgs = self.packages.${system};
};
checks = self.packages;
};
# XXX: fugly hack to work around literal quoting of attribute paths passed to `nixos-container`.
# without it we'd have to pass `x86_64-linux.<container>`, which will
Expand All @@ -40,7 +41,7 @@
packages.x86_64-linux = self.packages.x86_64-linux;
};

checks.x86_64-linux = self.packages.x86_64-linux;
#checks.x86_64-linux = self.packages.x86_64-linux;

};

Expand Down
2 changes: 1 addition & 1 deletion modules/all-modules.nix
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
{
liberaforms = import ./liberaforms.nix;
#Disabled because IDF# liberaforms = import ./liberaforms.nix;
}

0 comments on commit d851866

Please sign in to comment.