Skip to content

Commit

Permalink
Use php-composer-builder flake instead of forked nixpkgs
Browse files Browse the repository at this point in the history
  • Loading branch information
albertchae committed Aug 5, 2023
1 parent 7cb3e2b commit 4ba89df
Show file tree
Hide file tree
Showing 2 changed files with 8 additions and 8 deletions.
4 changes: 1 addition & 3 deletions all-packages.nix
Original file line number Diff line number Diff line change
@@ -1,10 +1,9 @@
{
newScope,
php-newScope,
...
}: let
self = rec {
flarum = php-callPackage ./pkgs/flarum {};
flarum = callPackage ./pkgs/flarum {};
gnunet-messenger-cli = callPackage ./pkgs/gnunet-messenger-cli {};
kikit = callPackage ./pkgs/kikit {};
liberaforms = callPackage ./pkgs/liberaforms {};
Expand All @@ -20,6 +19,5 @@
};

callPackage = newScope (self // nixpkgs-candidates // {inherit callPackage;});
php-callPackage = php-newScope (self // nixpkgs-candidates // {inherit callPackage;});
in
self
12 changes: 7 additions & 5 deletions flake.nix
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,7 @@
description = "NgiPkgs";

inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
inputs.php-nixpkgs.url = "github:drupol/nixpkgs?ref=php/add-new-builder";
inputs.nix-php-composer-builder.url = "github:loophp/nix-php-composer-builder";
inputs.flake-utils.url = "github:numtide/flake-utils";
# Set the defaultSystem list for flake-utils to only x86_64-linux
inputs.systems.url = "github:nix-systems/x86_64-linux";
Expand All @@ -13,19 +13,21 @@
outputs = {
self,
nixpkgs,
php-nixpkgs,
nix-php-composer-builder,
flake-utils,
treefmt-nix,
...
}: let
buildOutputs = system: let
pkgs = nixpkgs.legacyPackages.${system};
php-pkgs = php-nixpkgs.legacyPackages.${system};
pkgs = nixpkgs.legacyPackages.${system} {
overlays = [
inputs.nix-php-composer-builder.overlays.default
];
};
treefmtEval = treefmt-nix.lib.evalModule pkgs ./treefmt.nix;
in {
packages = import ./all-packages.nix {
inherit (pkgs) newScope;
php-newScope = php-pkgs.newScope;
};
nixosModules = {
modules = import ./modules/all-modules.nix;
Expand Down

0 comments on commit 4ba89df

Please sign in to comment.