-
Notifications
You must be signed in to change notification settings - Fork 1.2k
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Merge pull request #17403 from podsvirov/python-sqlmodel-new-package
python-sqlmodel: New package
- Loading branch information
Showing
2 changed files
with
68 additions
and
0 deletions.
There are no files selected for viewing
10 changes: 10 additions & 0 deletions
10
mingw-w64-python-sqlmodel/0001-sqlmodel-0.0.12-fix-version.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,10 @@ | ||
--- sqlmodel-0.0.12/pyproject.toml 2023-11-18 14:32:59.000000000 +0300 | ||
+++ python-build-MINGW32/pyproject.toml 2023-11-18 17:20:03.677492500 +0300 | ||
@@ -1,6 +1,6 @@ | ||
[tool.poetry] | ||
name = "sqlmodel" | ||
-version = "0" | ||
+version = "0.0.12" | ||
description = "SQLModel, SQL databases in Python, designed for simplicity, compatibility, and robustness." | ||
authors = ["Sebastián Ramírez <tiangolo@gmail.com>"] | ||
readme = "README.md" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,58 @@ | ||
# Maintainer: Konstantin Podsvirov <konstantin@podsvirov.pro> | ||
|
||
_realname=sqlmodel | ||
pkgbase=mingw-w64-python-${_realname} | ||
pkgname=("${MINGW_PACKAGE_PREFIX}-python-${_realname}") | ||
pkgver=0.0.12 | ||
pkgrel=1 | ||
pkgdesc='SQLModel, SQL databases in Python, designed for simplicity, compatibility, and robustness (mingw-w64)' | ||
arch=('any') | ||
mingw_arch=('mingw32' 'mingw64' 'ucrt64' 'clang64' 'clang32' 'clangarm64') | ||
url='https://github.com/tiangolo/sqlmodel' | ||
license=('MIT') | ||
depends=("${MINGW_PACKAGE_PREFIX}-python" | ||
"${MINGW_PACKAGE_PREFIX}-python-pydantic" | ||
"${MINGW_PACKAGE_PREFIX}-python-sqlalchemy") | ||
makedepends=("${MINGW_PACKAGE_PREFIX}-python-build" | ||
"${MINGW_PACKAGE_PREFIX}-python-installer" | ||
"${MINGW_PACKAGE_PREFIX}-python-poetry" | ||
"${MINGW_PACKAGE_PREFIX}-python-wheel" | ||
"git") | ||
source=("${_realname}-$pkgver.tar.gz::${url}/archive/${pkgver}.tar.gz" | ||
'0001-sqlmodel-0.0.12-fix-version.patch') | ||
sha256sums=('d13e99029dbd380e205819f19e09261c55cf9ed2a92dac5a0289a4856db5ec3b' | ||
'ab42603d5f951cdab485ee1ef96264ca32a6ff4f9545ca27961cdf5e8f2fd52d') | ||
|
||
apply_patch_with_msg() { | ||
for _patch in "$@" | ||
do | ||
msg2 "Applying $_patch" | ||
patch -Nbp1 -i "${srcdir}/$_patch" | ||
done | ||
} | ||
|
||
prepare() { | ||
rm -rf "python-build-${MSYSTEM}" | true | ||
cp -r "${_realname}-${pkgver}" "python-build-${MSYSTEM}" | ||
cd "python-build-${MSYSTEM}" | ||
|
||
apply_patch_with_msg \ | ||
0001-sqlmodel-0.0.12-fix-version.patch | ||
} | ||
|
||
build() { | ||
msg "Python build for ${MSYSTEM}" | ||
cd "${srcdir}/python-build-${MSYSTEM}" | ||
|
||
${MINGW_PREFIX}/bin/python -m build --wheel --skip-dependency-check --no-isolation | ||
} | ||
|
||
package() { | ||
cd "${srcdir}/python-build-${MSYSTEM}" | ||
|
||
MSYS2_ARG_CONV_EXCL="--prefix=" \ | ||
"${MINGW_PREFIX}"/bin/python -m installer --prefix=${MINGW_PREFIX} \ | ||
--destdir="${pkgdir}" dist/*.whl | ||
|
||
install -Dm644 LICENSE "${pkgdir}${MINGW_PREFIX}/share/licenses/python-${_realname}/LICENSE" | ||
} |