Skip to content

Commit

Permalink
Release 2.10.2 (#820)
Browse files Browse the repository at this point in the history
### Changes

- Added a view transaction `factory_get_wnear_address` for returning
address for the `wNEAR` ERC-20 contract by [@aleksuss]. ([#807])

### Fixes

- Fixed a bug where standalone engine can crash on tracing transactions
with too large contract deployment by [@birchmd]. ([#817])
- Fixed a bug and performance improvements with unusual exponents in the
`engine-modexp` crate by [@guidovranken]. ([#814])

---------

Co-authored-by: Guido Vranken <guidovranken@users.noreply.github.com>
Co-authored-by: Michael Birch <michael.birch@aurora.dev>
Co-authored-by: Joshua J. Bouw <joshua@aurora.dev>
  • Loading branch information
4 people authored Aug 10, 2023
1 parent 6c3d46e commit 17b6d69
Show file tree
Hide file tree
Showing 36 changed files with 951 additions and 419 deletions.
17 changes: 6 additions & 11 deletions .github/workflows/builds.yml
Original file line number Diff line number Diff line change
Expand Up @@ -22,29 +22,24 @@ jobs:
cargo make --profile ${{ matrix.profile }} build-xcc-docker
- run: ls -lH bin/aurora-*${{ matrix.profile }}.wasm
- name: Upload aurora-${{ matrix.profile }}.wasm artifact
uses: actions/upload-artifact@v2
uses: actions/upload-artifact@v3
with:
name: aurora-${{ matrix.profile }}.wasm
path: bin/aurora-${{ matrix.profile }}.wasm
- name: Upload aurora-factory-${{ matrix.profile }}.wasm artifact
uses: actions/upload-artifact@v2
with:
name: aurora-factory-${{ matrix.profile }}.wasm
path: bin/aurora-factory-${{ matrix.profile }}.wasm
name: contracts
path: bin/aurora*${{ matrix.profile }}.wasm

publish:
name: Publish contracts
runs-on: [self-hosted, heavy]
needs: build
steps:
- name: Download artifacts
uses: actions/download-artifact@v2
uses: actions/download-artifact@v3
- run: ls -la contracts
- name: Publish contracts for ${{ github.ref }} release
uses: svenstaro/upload-release-action@v2
with:
tag: ${{ github.ref }}
file: aurora*.wasm
overwrite: true
file: contracts/aurora*.wasm
repo_token: ${{ secrets.GITHUB_TOKEN }}
file_glob: true
env:
Expand Down
2 changes: 0 additions & 2 deletions .github/workflows/lints.yml
Original file line number Diff line number Diff line change
Expand Up @@ -40,8 +40,6 @@ jobs:
git checkout -f $(git -c user.name=x -c user.email=x@x commit-tree $(git hash-object -t tree /dev/null) < /dev/null) || :
- name: Clone the repository
uses: actions/checkout@v3
- name: Update udeps
run: cargo install --force cargo-udeps
- name: Run udeps
run: cargo make udeps
contracts:
Expand Down
2 changes: 1 addition & 1 deletion .github/workflows/tests.yml
Original file line number Diff line number Diff line change
Expand Up @@ -18,7 +18,7 @@ jobs:
- name: Clone the repository
uses: actions/checkout@v3
- name: Restore cache
run: cache-util restore cargo_git cargo_registry yarn_cache rocksdb:/root/rocksdb
run: cache-util restore cargo_git cargo_registry yarn_cache
- name: Build contracts
run: cargo make build-contracts
- name: Test contracts
Expand Down
23 changes: 20 additions & 3 deletions CHANGES.md
Original file line number Diff line number Diff line change
Expand Up @@ -7,6 +7,21 @@ and this project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0

## [Unreleased]

## [2.10.2] 2023-08-10

### Changes

- Added a view transaction `factory_get_wnear_address` for returning address for the `wNEAR` ERC-20 contract by [@aleksuss]. ([#807])

### Fixes

- Fixed a bug where standalone engine can crash on tracing transactions with too large contract deployment by [@birchmd]. ([#817])
- Fixed a bug and performance improvements with unusual exponents in the `engine-modexp` crate by [@guidovranken]. ([#814])

[#817]: https://github.com/aurora-is-near/aurora-engine/pull/817
[#814]: https://github.com/aurora-is-near/aurora-engine/pull/814
[#807]: https://github.com/aurora-is-near/aurora-engine/pull/807

## [2.10.1] 2023-07-27

### Fixes
Expand Down Expand Up @@ -449,7 +464,8 @@ struct SubmitResult {

## [1.0.0] - 2021-05-12

[Unreleased]: https://github.com/aurora-is-near/aurora-engine/compare/2.10.1...develop
[Unreleased]: https://github.com/aurora-is-near/aurora-engine/compare/2.10.2...develop
[2.10.2]: https://github.com/aurora-is-near/aurora-engine/compare/2.10.1...2.10.2
[2.10.1]: https://github.com/aurora-is-near/aurora-engine/compare/2.10.0...2.10.1
[2.10.0]: https://github.com/aurora-is-near/aurora-engine/compare/2.9.3...2.10.0
[2.9.3]: https://github.com/aurora-is-near/aurora-engine/compare/2.9.2...2.9.3
Expand Down Expand Up @@ -492,12 +508,13 @@ struct SubmitResult {
[@andrcmdr]: https://github.com/andrcmdr
[@birchmd]: https://github.com/birchmd
[@Casuso]: https://github.com/Casuso
[@guidovranken]: https://github.com/guidovranken
[@hskang9]: https://github.com/hskang9
[@joshuajbouw]: https://github.com/joshuajbouw
[@mandreyel]: https://github.com/mandreyel
[@matklad]: https://github.com/matklad
[@mfornet]: https://github.com/mfornet
[@mrLSD]: https://github.com/mrLSD
[@olonho]: https://github.com/olonho
[@RomanHodulak]: https://github.com/RomanHodulak
[@sept-en]: https://github.com/sept-en
[@matklad]: https://github.com/matklad
[@olonho]: https://github.com/olonho
45 changes: 34 additions & 11 deletions Cargo.lock

Some generated files are not rendered by default. Learn more about how customized files appear on GitHub.

1 change: 1 addition & 0 deletions Cargo.toml
Original file line number Diff line number Diff line change
Expand Up @@ -59,6 +59,7 @@ serde = { version = "1", default-features = false, features = ["alloc", "derive"
serde_json = { version = "1", default-features = false, features = ["alloc"] }
sha2 = { version = "0.10", default-features = false }
sha3 = { version = "0.10", default-features = false }
strum = { version = "0.25", features = ["derive"] }
tempfile = "3"
tokio = { version = "1", default-features = false, features = ["macros"] }
test-case = "3.1"
Expand Down
4 changes: 2 additions & 2 deletions Makefile.toml
Original file line number Diff line number Diff line change
Expand Up @@ -300,7 +300,7 @@ run_task = "build-engine-flow-docker"
[tasks.build-docker]
category = "Build"
script = '''
docker run --volume $PWD:/host -w /host -i --rm nearprotocol/contract-builder:master-1f62a6883f3b99094267f33f9045954ab29af1d8-amd64 ./scripts/docker-entrypoint.sh ${PROFILE}
docker run --volume $PWD:/host -w /host -i --rm nearprotocol/contract-builder:master-de975ed75e0f6a840c7aeb57e3414959cb59bc00-amd64 ./scripts/docker-entrypoint.sh ${PROFILE}
'''

[tasks.build-xcc-router-docker-inner]
Expand All @@ -312,7 +312,7 @@ run_task = "build-xcc-router-flow-docker"
[tasks.build-xcc-docker]
category = "Build"
script = '''
docker run --volume $PWD:/host -w /host -i --rm nearprotocol/contract-builder:master-1f62a6883f3b99094267f33f9045954ab29af1d8-amd64 ./scripts/docker-xcc-router-entrypoint.sh ${PROFILE}
docker run --volume $PWD:/host -w /host -i --rm nearprotocol/contract-builder:master-de975ed75e0f6a840c7aeb57e3414959cb59bc00-amd64 ./scripts/docker-xcc-router-entrypoint.sh ${PROFILE}
'''

[tasks.test-contracts]
Expand Down
2 changes: 1 addition & 1 deletion VERSION
Original file line number Diff line number Diff line change
@@ -1 +1 @@
2.10.1
2.10.2
6 changes: 3 additions & 3 deletions engine-modexp/Cargo.toml
Original file line number Diff line number Diff line change
Expand Up @@ -13,9 +13,9 @@ autobenches = false
[dependencies]
hex.workspace = true
num.workspace = true
ibig.workspace = true
ibig = { workspace = true, optional = true }

[features]
default = ["std"]
std = ["num/std", "ibig/std", "hex/std"]
bench = []
std = ["num/std", "hex/std"]
bench = ["ibig"]
Loading

0 comments on commit 17b6d69

Please sign in to comment.