Skip to content

Commit

Permalink
fix(app-containers/lazydocker): version bump to 0.24.1, drop old
Browse files Browse the repository at this point in the history
  • Loading branch information
SpiderX committed Jan 19, 2025
1 parent 273ecd3 commit 7a00b69
Show file tree
Hide file tree
Showing 3 changed files with 8 additions and 12 deletions.
2 changes: 1 addition & 1 deletion app-containers/lazydocker/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1 @@
DIST lazydocker-0.12.tar.gz 12045937 BLAKE2B a7cf22efd9f8b8898e447194a5434a30d1bbe1837709980253ab054aaba88f0db20f0e82e8cee13900d521a637ca4a84649c415403714ed1089942a6214721ac SHA512 59198b2f8e7c7c0686d4b1ddef3f585411e672055ede5f6a279c28cd8d94ba619078658d5b8f6c43915667f8180feb7d9407ea1003b3bc3b642e1502a165c78e
DIST lazydocker-0.24.1.tar.gz 12548859 BLAKE2B 3931aace12de32c6c9319fe48c1f74892293bfeeb9f207dfb451efdab236c5e38517b5ec65a02331a06dd4ac93fcf17dcd0997a78c7e6053e056eacdccbc9331 SHA512 6e9d3fcb16a274d797578cf2c38eb5ce29570bd65294fe9ca8a499e06a470f5193d8fa27a6566435f1014cef5dad48afa5101461512ab92abf66a53c1251c773
Original file line number Diff line number Diff line change
@@ -1,11 +1,11 @@
# Copyright 1999-2022 Gentoo Authors
# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit go-module

COMMIT="6fd5337"
COMMIT="be05115"

DESCRIPTION="Lazier way to manage everything docker"
HOMEPAGE="https://github.com/jesseduffield/lazydocker"
Expand All @@ -22,12 +22,11 @@ src_compile() {
LDFLAGS="-s -w -X main.version=${PV} -X \"main.date=${DATE}\"
-X main.buildSource=tarball -X main.commit=${COMMIT}"

GOFLAGS="-v -x -mod=vendor" \
go build -ldflags "${LDFLAGS}" -trimpath || die "build failed"
GOFLAGS="-v -x -mod=vendor" ego build -ldflags "${LDFLAGS}"
}

src_test() {
go test -work ./... || die "test failed"
ego test -work ./...
}

src_install() {
Expand Down
9 changes: 3 additions & 6 deletions app-containers/lazydocker/lazydocker-9999.ebuild
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# Copyright 1999-2022 Gentoo Authors
# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
Expand All @@ -9,11 +9,9 @@ inherit git-r3 go-module

DESCRIPTION="Lazier way to manage everything docker"
HOMEPAGE="https://github.com/jesseduffield/lazydocker"
SRC_URI=""

LICENSE="MIT"
SLOT="0"
KEYWORDS=""
RESTRICT="test"
PROPERTIES="test_network"

Expand All @@ -27,12 +25,11 @@ src_compile() {
LDFLAGS="-s -w -X main.version=${PV} -X \"main.date=${DATE}\"
-X main.buildSource=git -X main.commit=${COMMIT}"

GOFLAGS="-v -x -mod=vendor" \
go build -ldflags "${LDFLAGS}" -trimpath || die "build failed"
GOFLAGS="-v -x -mod=vendor" ego build -ldflags "${LDFLAGS}"
}

src_test() {
go test -work ./... || die "test failed"
ego test -work ./...
}

src_install() {
Expand Down

0 comments on commit 7a00b69

Please sign in to comment.