Skip to content

Commit

Permalink
Hailo BSP v1.4.0
Browse files Browse the repository at this point in the history
Bump to v1.4.0
Add WiFi support
Add HB IIoT carrier support
  • Loading branch information
mdanikin committed Aug 15, 2024
1 parent 878a119 commit 50dbcfe
Show file tree
Hide file tree
Showing 21 changed files with 1,222,173 additions and 349 deletions.
5 changes: 4 additions & 1 deletion .github/workflows/build.yml
Original file line number Diff line number Diff line change
Expand Up @@ -111,6 +111,7 @@ jobs:
export BB_ENV_PASSTHROUGH_ADDITIONS="$BB_ENV_PASSTHROUGH_ADDITIONS CACHE_DIR"
echo "require conf/includes/ci.conf" >> conf/local.conf
cat conf/local.conf
bitbake core-image-minimal --runall=fetch
bitbake core-image-minimal
- name: Update cache on the server
Expand Down Expand Up @@ -139,6 +140,8 @@ jobs:
cp $BUILD_PATH/fitImage deploy/
cp $BUILD_PATH/hailo15_scu_bl.bin deploy/
cp $BUILD_PATH/hailo15_scu_fw.bin deploy/
cp $BUILD_PATH/scu_bl_cfg_a.bin deploy/
cp $BUILD_PATH/scu_bl_cfg_b.bin deploy/
cp $BUILD_PATH/u-boot.dtb.signed deploy/
cp $BUILD_PATH/u-boot-initial-env deploy/
cp $BUILD_PATH/u-boot-spl.bin deploy/
Expand Down Expand Up @@ -178,7 +181,7 @@ jobs:
run: |
mkdir -p s3
tar cJf s3/solidrun-hailo15_${{ needs.build_images.outputs.build_tag }}.tar.xz \
deploy/*
-C deploy/ .
- name: Upload to S3
uses: shallwefootball/upload-s3-action@v1.3.3
Expand Down
8 changes: 4 additions & 4 deletions conf/docker/Dockerfile
Original file line number Diff line number Diff line change
Expand Up @@ -22,7 +22,7 @@ RUN apt-get update && apt-get install -y apt-transport-https \
python3-subunit mesa-common-dev patchelf \
zstd liblz4-tool file locales libacl1 \
tree sudo locales ca-certificates \
bash icecc
bash icecc tmux

RUN locale-gen en_US.UTF-8

Expand All @@ -32,9 +32,9 @@ RUN update-ca-certificates
RUN python3 -m pip install kas

# Set environment variables
ENV LANG=en_US.UTF-8 \
LANGUAGE=en_US:en \
LC_ALL=en_US.UTF-8
ENV LANG en_US.UTF-8
ENV LANGUAGE en_US:en
ENV LC_ALL en_US.UTF-8

# Arguments to pass host user's UID and GID
ARG USER_ID=1000
Expand Down
2 changes: 2 additions & 0 deletions conf/includes/ci.conf
Original file line number Diff line number Diff line change
Expand Up @@ -15,3 +15,5 @@ INHERIT += "icecc"

INHERIT += "rm_work"

ICECC_RECIPE_DISABLE += "libgsthailo"
CCACHE_DISABLE:pn-libgsthailo = "1"
4 changes: 2 additions & 2 deletions conf/includes/hailo_demo.conf
Original file line number Diff line number Diff line change
Expand Up @@ -12,7 +12,7 @@ PACKAGECONFIG:append:pn-gstreamer1.0 = " gst-tracer-hooks tracer-hooks coretrace
ADD_GSTREAMER_TO_IMAGE = "true"

# hailo-integrated-nnc
CORE_IMAGE_EXTRA_INSTALL:append = " hailo-integrated-nnc"
CORE_IMAGE_EXTRA_INSTALL:append = " hailo-integrated-nnc"

# hailo15-nnc-fw
CORE_IMAGE_EXTRA_INSTALL:append = " hailo15-nnc-fw"
Expand All @@ -25,7 +25,7 @@ CORE_IMAGE_EXTRA_INSTALL:append = " libhailort"
CORE_IMAGE_EXTRA_INSTALL:append = " hailortcli"

# media-library
CORE_IMAGE_EXTRA_INSTALL:append = " libgstmedialib libencoderosd"
CORE_IMAGE_EXTRA_INSTALL:append = " libgstmedialib"

# opencv
CORE_IMAGE_EXTRA_INSTALL:append = " opencv"
Expand Down
3 changes: 3 additions & 0 deletions conf/includes/sr_image.conf
Original file line number Diff line number Diff line change
@@ -1,3 +1,6 @@
# Image settings
IMAGE_INSTALL:append = " bmap-tools"
IMAGE_FSTYPES:append = " wic.bmap wic.xz"

IMAGE_INSTALL:append = " bluez5"
IMAGE_INSTALL:append = " connman connman-client"
4 changes: 4 additions & 0 deletions conf/machine/hailo15-solidrun.conf
Original file line number Diff line number Diff line change
Expand Up @@ -10,3 +10,7 @@ MACHINE_ESSENTIAL_EXTRA_RDEPENDS += "kernel-module-brcmfmac \
linux-firmware-bcm43455 \
"
MACHINE_FEATURES += "bluetooth wifi"

KERNEL_DEVICETREE:append = " \
${LINUX_YOCTO_HAILO_BOARD_VENDOR}/hailo15-solidrun-hb-pro.dtb \
"
1 change: 0 additions & 1 deletion kas/hailo15-solidrun.yaml
Original file line number Diff line number Diff line change
Expand Up @@ -15,7 +15,6 @@ local_conf_header:
meta-solidrun-arm-hailo: |
require conf/includes/sr_image.conf
require conf/includes/hailo_demo.conf
MACHINE_FEATURES += "imx334"
repos:
meta-solidrun-arm-hailo:
Expand Down
5 changes: 2 additions & 3 deletions kas/meta-hailo-soc.yaml
Original file line number Diff line number Diff line change
Expand Up @@ -4,7 +4,7 @@ header:
repos:
meta-hailo-soc:
url: https://github.com/hailo-ai/meta-hailo-soc/
commit: 860c3728b3d2e8ae09e5b35a012bb64ef7750cdb
commit: a3784cced763ea7e17f05acfb9912682e570a327
layers:
meta-hailo-bsp-examples: excluded
meta-hailo-bsp:
Expand All @@ -15,9 +15,8 @@ repos:

meta-hailo:
url: "https://github.com/hailo-ai/meta-hailo.git"
commit: ee95e0594a860177511ab492fd275c4727f6c52f
commit: 5d52200a54ede32230e5edc68d42ac402beeabb4
layers:
meta-hailo-libhailort:
meta-hailo-vpu:
meta-hailo-tappas:

115 changes: 115 additions & 0 deletions recipes-bsp/linux-firmware/files/brcmfmac43455-sdio.hailo,hailo15.txt
Original file line number Diff line number Diff line change
@@ -0,0 +1,115 @@
# Cloned from bcm94345wlpagb.txt
NVRAMRev=$Rev: 498373 $
sromrev=11
vendid=0x14e4
devid=0x43ab
manfid=0x2d0
prodid=0x06e4
macaddr=00:90:4c:c5:12:38
nocrc=1
boardtype=0x6e4

##boardrev - superseded by the one in OTP
boardrev=0x1100
xtalfreq=37400
## tune where necessary
#xtal_swcapio=0x6644
boardflags=0x00080201
boardflags2=0x40000000
boardflags3=0x44200100
rxchain=1
txchain=1
aa2g=1
aa5g=1
tssipos5g=1
tssipos2g=1
AvVmid_c0=0,157,1,126,1,126,1,126,1,126
pa2ga0=-152,5969,-666
pa2ga1=-143,4076,-546
pa5ga0=-165,5736,-689,-169,5710,-692,-171,5713,-688,-173,5732,-689
#pa5ga1=-161,3672,-510,-166,3671,-508,-169,3697,-508,-171,3854,-520
itrsw=1
pdoffset40ma0=0x9999
pdoffset80ma0=0x8888
extpagain5g=2
extpagain2g=2
maxp2ga0=74
cckbw202gpo=0x0000
ofdmlrbw202gpo=0x0022
dot11agofdmhrbw202gpo=0x8888
mcsbw202gpo=0xaaaaa666
maxp5ga0=76,76,76,76
mcsbw205glpo=0x99999955
mcsbw205gmpo=0x99999955
mcsbw205ghpo=0x99999955
mcsbw405glpo=0xff999555
mcsbw405gmpo=0xff999555
mcsbw405ghpo=0xff999555
mcsbw805glpo=0xfffffbbb
mcsbw805gmpo=0xfffffbbb
mcsbw805ghpo=0xfffffbbb
swctrlmap_2g=0x00040004,0x00020002,0x00040004,0x010a02,0x1ff
swctrlmap_5g=0x00100010,0x00200020,0x00200020,0x010a02,0x2f4
swctrlmapext_5g=0x00000000,0x00000000,0x00000000,0x000000,0x000
swctrlmapext_2g=0x00000000,0x00000000,0x00000000,0x000000,0x000
vcodivmode=1
##filter parameters -- tune where necessary
cckdigfilttype=6
fdss_level_2g=2
fdss_level_5g=2
## added by apps
aga0=0x1
agbg0=0x1
ccode=0
ed_thresh2g=-65
ed_thresh5g=-65
ltecxmux=0
ltecxpadnum=0x0504
ltecxfnsel=0x22
ltecxgcigpio=0x32
pdoffsetcckma0=0x0000
powoffs2gtna0=0,0,0,0,0,0,0,0,0,0,0,0,0,0
tempthresh=120
temps_hysteresis=15
rawtempsense=0x1ff
tworangetssi2g=1
tworangetssi5g=0
lowpowerrange2g=0
lowpowerrange5g=0
ag0=1
ag1=1
#subband5gver=0x4
mcslr5glpo=0x0000
mcslr5gmpo=0x0000
mcslr5ghpo=0x0000
sb20in40hrpo=0x0
sb20in80and160hr5glpo=0x0
sb40and80hr5glpo=0x0
sb20in80and160hr5gmpo=0x0
sb40and80hr5gmpo=0x0
sb20in80and160hr5ghpo=0x0
sb40and80hr5ghpo=0x0
sb20in40lrpo=0x0
sb20in80and160lr5glpo=0x0
sb40and80lr5glpo=0x0
sb20in80and160lr5gmpo=0x0
sb40and80lr5gmpo=0x0
sb20in80and160lr5ghpo=0x0
sb40and80lr5ghpo=0x0
dot11agduphrpo=0x0
dot11agduplrpo=0x0
phycal_tempdelta=25
temps_period=15
btc_mode=1
sbpowoffs5g20mtna0=0,0,0,0
sbpowoffs5g40mtna0=0,0,0,0
sbpowoffs5g80mtna0=0,0,0,0
powoffs5g20mtna0=0,0,0,0,0,0,0
powoffs5g40mtna0=0,0,0,0,0
powoffs5g80mtna0=0,0,0,0,0
ldo1=5
cbfilttype=2
xtal_swcapio=0x8855
fdss_level_ch13=1,1
# muxenab defined to enable OOB IRQ. Level sensitive interrupt via WL_HOST_WAKE line.
muxenab=0x10
13 changes: 13 additions & 0 deletions recipes-bsp/linux-firmware/linux-firmware_%.bbappend
Original file line number Diff line number Diff line change
@@ -0,0 +1,13 @@
# Solidrun hailo15 SOM WiFi settings

FILESEXTRAPATHS:prepend := "${THISDIR}/files:"

SRC_URI:append = " \
file://brcmfmac43455-sdio.hailo,hailo15.txt \
"

do_install:append() {
cp ${WORKDIR}/brcmfmac43455-sdio.hailo,hailo15.txt ${D}${nonarch_base_libdir}/firmware/brcm
cd ${D}${nonarch_base_libdir}/firmware/brcm
ln -s brcmfmac43455-sdio.bin brcmfmac43455-sdio.hailo,hailo15.bin
}
1 change: 1 addition & 0 deletions recipes-bsp/scu-bl/scu-bl.bbappend
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
addtask deploy after do_install
Original file line number Diff line number Diff line change
Expand Up @@ -362,3 +362,32 @@ index 0000000000..318226cba4
--
2.45.0

From 5b9daecc179a1f8ae422ca15f61bb105a4c248fe Mon Sep 17 00:00:00 2001
From: Mikhail Anikin <mikhail.anikin@solid-run.com>
Date: Wed, 22 May 2024 15:57:59 +0300
Subject: [PATCH] Update DDR binding

---
arch/arm/dts/hailo15-solidrun.dts | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/arch/arm/dts/hailo15-solidrun.dts b/arch/arm/dts/hailo15-solidrun.dts
index 0dca2f137e..e9322f5254 100644
--- a/arch/arm/dts/hailo15-solidrun.dts
+++ b/arch/arm/dts/hailo15-solidrun.dts
@@ -5,8 +5,8 @@
*/

#include "hailo15-base.dtsi"
-#include "hailo15_ddr_MT53E1G32D2FW-046_configuration.dtsi"
-#include "hailo15_ddr_MT53E1G32D2FW-046_regconfig_ca_odtb_pd.dtsi"
+#include "hailo15_ddr_configuration.dtsi"
+#include "hailo15_ddr_MT53E1G32D2FW-046_regconfig_ca_odtb_pd_4GB.dtsi"
#include <dt-bindings/gpio/gpio.h>

/ {
--
2.43.2



Loading

0 comments on commit 50dbcfe

Please sign in to comment.